about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-08-30 05:10:40 +0000
committerEric Wong <e@80x24.org>2023-08-30 05:27:33 +0000
commit82cef98a1d43e233d8dd1fff1f3759ee716067c7 (patch)
tree97405d31bb9f57ef6d32723ef1a01891809cb9f7 /Makefile.PL
parent900cb902886ce7aa257b866bcf8380f1b935c64a (diff)
downloadpublic-inbox-82cef98a1d43e233d8dd1fff1f3759ee716067c7.tar.gz
Mixing various quoting and escaping rules between shell, make,
and Perl got confusing in Makefile.PL :x  This hopefully sorts
out my confusion.

We'll also fix and use TEST_XH_CXX_ONLY=1 to avoid needlessly
running the tests on the XS||SWIG implementation when we're
checking for memory errors.

Fixes: 2312ca26023fcbe3 (makefile: add targets for ASan and valgrind)
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5865a252..d2309336 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -264,12 +264,13 @@ lib/PublicInbox.pm : FORCE
         VERSION=\$(VERSION) \$(PERL) -w ./version-gen.perl
 
 test-asan : pure_all
-        CXXFLAGS='-O0 -Wall -ggdb3 -fsanitize=address' \
+        TEST_XH_CXX_ONLY=1 CXXFLAGS='-O0 -Wall -ggdb3 -fsanitize=address' \\
                 prove -bvw t/xap_helper.t
 
-VG_OPT = '-v --trace-children=yes --track-fds=yes'
-VG_OPT += ' --leak-check=yes --track-origins=yes'
+VG_OPT = -v --trace-children=yes --track-fds=yes
+VG_OPT += --leak-check=yes --track-origins=yes
 test-valgrind : pure_all
-        VALGRIND="valgrind \$\$(VG_OPT)" prove -bvw t/xap_helper.t
+        TEST_XH_CXX_ONLY=1 VALGRIND="valgrind \$(VG_OPT)" \\
+                prove -bvw t/xap_helper.t
 EOF
 }