about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2021-05-04 04:15:44 +0000
committerEric Wong <e@80x24.org>2021-05-04 04:17:10 +0000
commiteb99e6d0a50ba2e03870b21b165e37a64ce745bd (patch)
treedb2f229f03391c5b00e5004479ab72b65a3854cc /Makefile.PL
parent0b15dfc58ceaecdcb1c9285c3ad55813006c8338 (diff)
downloadpublic-inbox-eb99e6d0a50ba2e03870b21b165e37a64ce745bd.tar.gz
This failure was also passing under FreeBSD make + /bin/sh;
so we also avoid the '&&' chain is avoided and use '>$@' as a
separate line in the Makefile.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 85b18e7d..401c033e 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -72,7 +72,8 @@ for my $i (@sections) {
                 $t->{"Documentation/$m.html : $txt"} = [ "\$(txt2pre) <$txt" ];
                 $t->{".$m.cols : $m.$i"} = [
                         "\@echo CHECK80 $m.$i;".
-                        "COLUMNS=80 \$(MAN) ./$m.$i | \$(check_man)" ];
+                        "COLUMNS=80 \$(MAN) ./$m.$i | \$(check_man)",
+                        '>$@' ];
                 $t->{".$m.lexgrog: $m.$i"} = [
                         "\@echo LEXGROG $m.$i;" .
                         "\$(LEXGROG) ./$m.$i >\$\@+ && mv \$\@+ \$@" ];