about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2024-04-25 21:31:46 +0000
committerEric Wong <e@80x24.org>2024-04-28 17:05:29 +0000
commitcccff5cbaf8e9800dbcb67dd497586bdb0a8521e (patch)
treeda3292d5a6d59509fbac435479620fd44d2aee1b /Makefile.PL
parentbad65d1197b8ee45a28e8bb7c894912145012fb5 (diff)
downloadpublic-inbox-cccff5cbaf8e9800dbcb67dd497586bdb0a8521e.tar.gz
Xapian helper processes are disabled by default once again.
However, they can be enabled via the new `-X INTEGER' parameter.
One big positive is the Xapian helpers being spawned by the
top-level daemon means they can be shared freely across all
workers for improved load balancing and memory reduction.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 2b2e6b18..27fe02ff 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -255,6 +255,12 @@ check-run : check-man
 # GNU and *BSD both allow it.
 check-run_T_ARGS = -j\$(N)
 
+check-xh0 :
+        \$(MAKE) check-run TEST_DAEMON_XH='-X0'
+
+check-xh1 :
+        \$(MAKE) check-run TEST_DAEMON_XH='-X1'
+
 check-debris check-run : pure_all
         \$(EATMYDATA) \$(PROVE) -bvw xt/\$@.t :: \$(\$\@_T_ARGS)
         -@\$(check_manifest)