about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-09-18 10:15:13 +0000
committerEric Wong <e@80x24.org>2023-09-20 19:14:23 +0000
commitae452a4116476cf9ed17b73c8df51492ce7624da (patch)
tree30c65f62a01c14857d45b8a08ce830f6d423ea89 /Makefile.PL
parenteb4ed924e9f8075ed134fbd590d390e208f4120f (diff)
downloadpublic-inbox-ae452a4116476cf9ed17b73c8df51492ce7624da.tar.gz
This non-portable construct isn't needed for our own rules.
I'm understanding them correctly, they have different
semantics between *BSDs and GNU make.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 9dc18b5c..81992e46 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -213,7 +213,7 @@ $VARS
 -include Documentation/include.mk
 $TGTS
 
-check-man :: $check_lexgrog$warn_no_pod
+check-man : $check_lexgrog$warn_no_pod
 
 # syntax checks are currently GNU make only:
 %.syntax :: %
@@ -231,24 +231,24 @@ check-manifest : MANIFEST
         \$(check_manifest)
 
 # the traditional way running per-*.t processes:
-check-each :: pure_all
+check-each : pure_all
         \$(EATMYDATA) \$(PROVE) --state=save -bvw -j\$(N)
         -@\$(check_manifest)
 
 # check-run relies "--state=save" in check-each for best performance
-check-run :: check-man
+check-run : check-man
 
 # n.b. while `-' isn't specified as an allowed make(1posix) macro name,
 # GNU and *BSD both allow it.
 check-run_T_ARGS = -j\$(N)
 
-check-debris check-run :: pure_all
+check-debris check-run : pure_all
         \$(EATMYDATA) \$(PROVE) -bvw xt/\$@.t :: \$(\$\@_T_ARGS)
         -@\$(check_manifest)
 
-check :: check-each
+check : check-each
 
-lib/PublicInbox/UserContent.pm :: contrib/css/216dark.css
+lib/PublicInbox/UserContent.pm : contrib/css/216dark.css
         \$(PERL) -I lib \$@ \$?
 
 # Ensure new .pm files will always be installed by updating
@@ -269,7 +269,7 @@ symlink-install : lib/PublicInbox.pm
                 ln -sf "\$\$lei" \$\$(basename "\$\$x"); \\
         done
 
-pure_all :: lib/PublicInbox.pm
+pm_to_blib : lib/PublicInbox.pm
 lib/PublicInbox.pm : FORCE
         VERSION=\$(VERSION) \$(PERL) -w ./version-gen.perl