about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2021-02-03 15:51:43 -0600
committerEric Wong <e@80x24.org>2021-02-04 01:41:04 +0000
commit92dd30285b579204b242df3e12b57b926083b666 (patch)
tree9a60d502bad9e13d53a49f44618a7389a9b462eb /Makefile.PL
parent3378cc4b85cc9ee091b7ae1b340e525e61e188ea (diff)
downloadpublic-inbox-92dd30285b579204b242df3e12b57b926083b666.tar.gz
The new IPC stuff doesn't work without Storable or Sereal.
Storable is part of the standard library since Perl 5.8, so
we'll put a hard dependency on it for distros that package
it separately.

Data::Dumper is also part of the standard library, and
PublicInbox::MboxReader uses it, and it's frequently useful
during development.

We'll also trim down INSTALL for standard library modules so
it's hopefully less daunting for new users.

Development dependencies are noted in HACKING, now.

Email::MIME is only used for maintainer tests, so it's only
documented in HACKING.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL17
1 files changed, 6 insertions, 11 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f1910c47..b9e0a8cd 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -145,24 +145,19 @@ WriteMakefile(
                 # We also depend on git.
                 # Keep this sorted and synced to the INSTALL document
 
-                # libperl$PERL_VERSION,
-                # `perl5' on FreeBSD
-                # perl-Digest-SHA on RH-based
-                'Digest::SHA' => 0,
-
-                # libperl$PERL_VERSION or libencode-perl on Debian,
-                # `perl5' on FreeBSD
-                'Encode' => 2.35, # 2.35 shipped with 5.10.1
-
-                # libperl$PERL_VERSION + perl-modules-$PERL_VERSION
+                # perl-modules-5.xx or libperl5.xx in Debian-based
+                # part of "perl5" on FreeBSD
                 'Compress::Raw::Zlib' => 0,
                 'Compress::Zlib' => 0,
+                'Data::Dumper' => 0,
+                'Digest::SHA' => 0, # rpm: perl-Digest-SHA
+                'Encode' => 2.35, # 2.35 shipped with 5.10.1
                 'IO::Compress::Gzip' => 0,
+                'Storable' => 0, # rpm: perl-Storable
 
                 # Plack is needed for public-inbox-httpd and PublicInbox::WWW
                 # 'Plack' => 0,
 
-                # TODO: this should really be made optional...
                 'URI::Escape' => 0,
 
                 # We have more test dependencies, but do not force