about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-09-18 10:15:16 +0000
committerEric Wong <e@80x24.org>2023-09-20 19:14:26 +0000
commit56a20a3e242cc0a4c1df0ab1c77b3cebf3e33aae (patch)
tree4dc436632f83d1204fe534cd29590d2eb8ce2032 /Makefile.PL
parent79874c84bad7c0c720751bdcc1a8398a2e50f885 (diff)
downloadpublic-inbox-56a20a3e242cc0a4c1df0ab1c77b3cebf3e33aae.tar.gz
which(1) isn't in POSIX so it's perhaps less likely to be
available (although I don't think I've noticed a system
without it in decades).  So replace it with the POSIX
`command -v', even though everyone seems to use which...

Add a note about `lexgrog', too, since I'm not sure if it's
packaged for various *BSDs.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 81992e46..8bd39e6c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -126,7 +126,7 @@ my %man3 = map {; # semi-colon tells Perl this is a BLOCK (and not EXPR)
         "lib/PublicInbox/$_" => "blib/man3/PublicInbox::$mod.\$(MAN3EXT)"
 } qw(Git.pm Import.pm WWW.pod SaPlugin/ListMirror.pod);
 my $warn_no_pod = @no_pod ? "\n\t\@echo W: missing .pod: @no_pod\n" : '';
-chomp(my $lexgrog = `which lexgrog 2>/dev/null`);
+chomp(my $lexgrog = `command -v lexgrog 2>/dev/null`);
 my $check_lexgrog = $lexgrog ? 'check-lexgrog' : '';
 
 WriteMakefile(