about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 7ea7929..eab1edb 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -31,6 +31,17 @@ END
 # may be empty
 chomp(my $INC = `$pkg_config --cflags liburcu-cds liburcu-bp`);
 my @writemakefile_args = ();
+my $ccflags = '';
+
+print '# checking libxxhash... ';
+chomp(my $xxhash_inc = `$pkg_config --cflags libxxhash`);
+if ($? == 0) {
+        $INC .= " $xxhash_inc";
+        $ccflags .= ' -DHAVE_XXHASH';
+        say 'yes';
+} else {
+        say 'no';
+}
 
 use IO::Handle;
 STDOUT->autoflush(1);
@@ -68,6 +79,7 @@ say " no on $^O" if $@;
 push @writemakefile_args, (
         NAME => 'Devel::Mwrap',
         VERSION_FROM => 'lib/Devel/Mwrap.pm',
+        CCFLAGS => "$Config{ccflags} $ccflags",
         PREREQ_PM => {},
         ABSTRACT_FROM => 'lib/Devel/Mwrap.pm',
         EXE_FILES => [qw(script/mwrap-perl)],