about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2022-12-27 22:00:42 +0000
committerEric Wong <mwrap-perl@80x24.org>2022-12-28 10:11:12 +0000
commit357587ad14a15f5ee10931977b0fda5f2d500fd9 (patch)
tree7ea94496e4e10eea4ed322f5f95b49465a958686 /Makefile.PL
parentb4bf880c8deac37445a493adf9c5eb42a168a486 (diff)
downloadmwrap-357587ad14a15f5ee10931977b0fda5f2d500fd9.tar.gz
Given the fragile change in
https://80x24.org/mwrap-perl/20221227141712.1473379-1-e@80x24.org/
to support addr2line(1), I am considering integrating the GPL-3
code for GNU addr2line into httpd.h directly.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f953d51..dadf80b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,5 +1,5 @@
 # Copyright (C) all contributors <mwrap-perl@80x24.org>
-# License: GPL-2.0+ <https://www.gnu.org/licenses/gpl-2.0.txt>
+# License: GPL-3.0+ <https://www.gnu.org/licenses/gpl-3.0.txt>
 use v5.12;
 use ExtUtils::MakeMaker;
 use Config;
@@ -86,7 +86,7 @@ push @writemakefile_args, (
         EXE_FILES => [qw(script/mwrap-perl script/mwrap-rproxy)],
         AUTHOR => 'mwrap hackers <mwrap-perl@80x24.org>',
         LIBS => $LIBS, # e.g. -lurcu-cds
-        LICENSE => 'gpl_2', # GPL-2.0+, CPAN::Meta::Spec limitation
+        LICENSE => 'gpl_2', # GPL-3.0+, CPAN::Meta::Spec limitation
         MIN_PERL_VERSION => '5.12.0',
         BUILD_REQUIRES => {},
         INC => $INC,