everything related to duct tape audio suite (dtas)
 help / color / mirror / Atom feed
* dtas-console doesn't work on my system
@ 2014-10-02 12:43 Rene Maurer
  2014-10-02 17:15 ` Eric Wong
  0 siblings, 1 reply; 3+ messages in thread
From: Rene Maurer @ 2014-10-02 12:43 UTC (permalink / raw)
  To: dtas-all

Since now I have never used 'dtas-console'. I have tried it the first
time and it doesn't work:

| dtas-conole

| /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in
| `require': cannot load such file -- curses (LoadError)

| from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in
| `require'

| from /home/rene/.gem/ruby/2.1.0/gems/dtas-0.7.0/bin/dtas-console:9:in
| `<top (required)>'

| from /home/rene/.gem/ruby/2.1.0/bin/dtas-console:23:in `load'
| from /home/rene/.gem/ruby/2.1.0/bin/dtas-console:23:in `<main>'

Other dtas components (dtas-player, dtas-ctl, dtas-enq) work fine.

Any hints are very welcome.

Best, René


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: dtas-console doesn't work on my system
  2014-10-02 12:43 dtas-console doesn't work on my system Rene Maurer
@ 2014-10-02 17:15 ` Eric Wong
  2014-10-03  4:42   ` Rene Maurer
  0 siblings, 1 reply; 3+ messages in thread
From: Eric Wong @ 2014-10-02 17:15 UTC (permalink / raw)
  To: Rene Maurer; +Cc: dtas-all

Rene Maurer <rmnet@mailc.net> wrote:
> Since now I have never used 'dtas-console'. I have tried it the first
> time and it doesn't work:
> 
> | dtas-conole
> 
> | /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in
> | `require': cannot load such file -- curses (LoadError)

I think you built/installed Ruby without the necessary dependencies for
the curses extension.  In any case, Ruby 2.2.0 split out "curses" as a
separate RubyGem.

You'll need the necessary build dependency (libncurses5-dev on Debian)
to build + install it:

	sudo apt-get install libncurses5-dev
	gem install curses

I think RH-based systems have named the build-dep "ncurses-devel" or
similar

> Other dtas components (dtas-player, dtas-ctl, dtas-enq) work fine.

Right, dtas-console is totally optional.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: dtas-console doesn't work on my system
  2014-10-02 17:15 ` Eric Wong
@ 2014-10-03  4:42   ` Rene Maurer
  0 siblings, 0 replies; 3+ messages in thread
From: Rene Maurer @ 2014-10-03  4:42 UTC (permalink / raw)
  To: dtas-all

Eric Wong <e@80x24.org> wrote:
> You'll need the necessary build dependency (libncurses5-dev on Debian)
> to build + install it:
> 
> 	sudo apt-get install libncurses5-dev  

I am on arch and 'ncurses-5.9' as well as 'ruby-ncurses-1.3' are
installed.

> 	gem install curses  

This does it. Sorry I am not familiar with the RubyGems system.

Thanks for helping!


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2014-10-03  6:20 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-10-02 12:43 dtas-console doesn't work on my system Rene Maurer
2014-10-02 17:15 ` Eric Wong
2014-10-03  4:42   ` Rene Maurer

everything related to duct tape audio suite (dtas)

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://80x24.org/dtas-all
	git clone --mirror http://ou63pmih66umazou.onion/dtas-all

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 dtas-all dtas-all/ https://80x24.org/dtas-all \
		dtas-all@nongnu.org
	public-inbox-index dtas-all

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.public-inbox.org/inbox.comp.audio.dtas
	nntp://ou63pmih66umazou.onion/inbox.comp.audio.dtas
 note: .onion URLs require Tor: https://www.torproject.org/

code repositories for the project(s) associated with this inbox:

	../../../dtas.git

AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git