about summary refs log tree commit
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 66c3df1..fe35c56 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -92,6 +92,29 @@ MAIN: {
                             }
                         }
                     }
+                },
+
+                SSL => {
+                    description => 'SSL support',
+                    prereqs => {
+                        runtime => {
+                            requires => {
+                                'IO::Socket::SSL' => '1.968'
+                            }
+                        }
+                    }
+                },
+
+                IPv6 => {
+                    description => 'IPv6 support',
+                    prereqs => {
+                        runtime => {
+                            requires => {
+                                'IO::Socket::IP' => '0.20'
+                            # or IO::Socket::INET6 2.62
+                            }
+                        }
+                    }
                 }
             }
         },