about summary refs log tree commit
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 80d7b1d..66c3df1 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -42,6 +42,14 @@ MAIN: {
     my %prereq_pms = ();
     $prereq_pms{'Convert::EBCDIC'} = '0.06' if $^O eq 'os390';
 
+    my $xt = prompt("Should I do external tests?\n" .
+        "These tests will fail if there is no internet connection or if a firewall\n" .
+        "blocks or modifies some traffic.\n" .
+        "[y/N]", 'n');
+
+    my $tests = 't/*.t';
+    $tests .= ' t/external/*.t' if $xt =~ m/^y/io;
+
     WriteMakefile(
         NAME     => 'Net',
         DISTNAME => 'libnet',
@@ -128,6 +136,10 @@ MAIN: {
             FILES => $CfgFile
         },
 
+        test => {
+            TESTS => $tests
+        },
+
         dist => {
             PREOP   => 'find $(DISTVNAME) -type d -print|xargs chmod 0755 && ' .
                        'find $(DISTVNAME) -type f -print|xargs chmod 0644',