about summary refs log tree commit
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSteve Hay <steve.m.hay@googlemail.com>2014-05-30 08:28:29 +0100
committerSteve Hay <steve.m.hay@googlemail.com>2014-05-30 08:28:29 +0100
commit1411576c71cd483c6e530fccd3d5545c23343a09 (patch)
tree44001c7120a6f94323704485b6b354da7f024d9a /Makefile.PL
parent2f1794c4fcc389dd5b01446d0d434cbad0914f48 (diff)
downloadperl-libnet-1411576c71cd483c6e530fccd3d5545c23343a09.tar.gz
Various metadata updates
- Fix missing resources from generated metadata files (the repository value
  must be a hash reference)
- Ensure minimum Perl version is stated for configure and test, not just
  for runtime
- Add previously commented-out requirements as optional features
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL84
1 files changed, 56 insertions, 28 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 564bc4f..86b334d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -56,7 +56,35 @@ MAIN: {
             },
 
             resources => {
-                repository => 'https://github.com/steve-m-hay/perl-libnet',
+                repository => {
+                    type => 'git',
+                    url  => 'https://github.com/steve-m-hay/perl-libnet.git'
+                }
+            },
+
+            optional_features => {
+                APOP => {
+                    description => 'APOP support',
+                    prereqs => {
+                        runtime => {
+                            requires => {
+                                'Digest::MD5' => '0'
+                            }
+                        }
+                    }
+                },
+
+                AUTH => {
+                    description => 'AUTH support',
+                    prereqs => {
+                        runtime => {
+                            requires => {
+                                'Authen::SASL' => '0',
+                                'MIME::Base64' => '0'
+                            }
+                        }
+                    }
+                }
             }
         },
 
@@ -64,38 +92,38 @@ MAIN: {
 
         CONFIGURE_REQUIRES => {
             'ExtUtils::MakeMaker' => '6.64',
-            'Getopt::Std'         => 0,
-            'IO:File'             => 0,
-            'strict'              => 0,
-            'vars'                => 0,
-            'warnings'            => 0
+            'Getopt::Std'         => '0',
+            'IO:File'             => '0',
+            'perl'                => '5.008001',
+            'strict'              => '0',
+            'vars'                => '0',
+            'warnings'            => '0'
         },
 
         TEST_REQUIRES => {
-            'Cwd'                 => 0,
-            'IO::File'            => 0,
-            'strict'              => 0
+            'Cwd'      => '0',
+            'IO::File' => '0',
+            'perl'     => '5.008001',
+            'strict'   => '0'
         },
 
         PREREQ_PM => {
             %prereq_pms,
-          # 'Authen::SASL'        => 0,      # Only required for AUTH support
-            'Carp'                => 0,
-          # 'Digest::MD5'         => 0,      # Only required for APOP support
-            'Errno'               => 0,
-            'Exporter'            => 0,
-            'Fcntl'               => 0,
-            'File::Basename'      => 0,
-            'FileHandle'          => 0,
-            'IO::Select'          => 0,
-            'IO::Socket'          => '1.05',
-          # 'MIME::Base64'        => 0,      # Only required for AUTH support
-            'POSIX'               => 0,
-            'Socket'              => '1.3',
-            'Symbol'              => 0,
-            'Time::Local'         => 0,
-            'strict'              => 0,
-            'vars'                => 0
+            'Carp'           => '0',
+            'Errno'          => '0',
+            'Exporter'       => '0',
+            'Fcntl'          => '0',
+            'File::Basename' => '0',
+            'FileHandle'     => '0',
+            'IO::Select'     => '0',
+            'IO::Socket'     => '1.05',
+            'POSIX'          => '0',
+            'Socket'         => '1.3',
+            'Symbol'         => '0',
+            'Time::Local'    => '0',
+            'perl'           => '5.008001',
+            'strict'         => '0',
+            'vars'           => '0'
         },
 
         INSTALLDIRS => 'perl',
@@ -105,8 +133,8 @@ MAIN: {
         },
 
         dist => {
-            PREOP   => 'find $(DISTVNAME) -type f -print|xargs chmod 0644 && ' .
-                       'find $(DISTVNAME) -type d -print|xargs chmod 0755',
+            PREOP   => 'find $(DISTVNAME) -type d -print|xargs chmod 0755 && ' .
+                       'find $(DISTVNAME) -type f -print|xargs chmod 0644',
             TO_UNIX => 'find $(DISTVNAME) -type f -print|xargs dos2unix'
         }
     );