about summary refs log tree commit
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2019-07-03 01:05:10 +0000
committerEric Wong <e@80x24.org>2019-07-03 01:12:18 +0000
commit0ab5c363a69702e586b7ef06be3ebff3e78656b7 (patch)
tree58b88dd6aeeb802272b457c0f13893eac08b94a6 /Makefile.PL
parentddd8d0adec2bbac86bbca40900acae2c56740e82 (diff)
downloadperl-libnet-0ab5c363a69702e586b7ef06be3ebff3e78656b7.tar.gz
Net::NNTP: support COMPRESS DEFLATE (RFC8054) nntp-compress
NNTP compression reduces bandwidth use significantly and is
supported in current versions of INN.

It is specified in https://tools.ietf.org/html/rfc8054

Tested on news.gmane.org (running INN) with and without STARTTLS.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index efbad99..463bd25 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -127,6 +127,16 @@ MAIN: {
                     }
                 },
 
+                COMPRESS => {
+                    description => 'NNTP COMPRESS support',
+                    prereqs => {
+                        runtime => {
+                            requires => {
+                                'Compress::Raw::Zlib' => 0
+                            }
+                        }
+                    }
+                },
                 changestest => {
                     description => 'Changes testing',
                     prereqs => {