about summary refs log tree commit
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-02-03 08:18:05 +0000
committerEric Wong <e@yhbt.net>2020-02-03 08:18:05 +0000
commite73e6b5e7fb0d7077ba6959ca155677779ae4681 (patch)
tree2e37b13aa3f15a9b41a27d284da28dbd0dba60f6
parent6f4b226bfcc822eaee68946bfb948e94d03b3b97 (diff)
downloaddtas-e73e6b5e7fb0d7077ba6959ca155677779ae4681.tar.gz
fiddle is now supported for Linux users without a C compiler or
Ruby headers installed to take advantage of inotify(7)
functionality and efficiency improvements with splice(2) and
eventfd(7).

For non-RubyGems users, there's some setup.rb fixes thanks
to James Rowe.

Eric Wong (8):
      doc: fixup leftover ftp://lists.gnu.org links
      pipe: avoid loading sleepy_penguin
      provide fiddle-based eventfd implementation
      buffer: replace sleepy_penguin with fiddle
      watchable: use fiddle for inotify support
      doc: remove most recommendations for sleepy_penguin
      INSTALL: s/bogomips.org/yhbt.net/
      doc: update copyrights for 2020

James Rowe (2):
      setup: update to use RbConfig
      setup: fix duplicate variable warning
-rwxr-xr-xGIT-VERSION-GEN2
-rw-r--r--INSTALL6
2 files changed, 4 insertions, 4 deletions
diff --git a/GIT-VERSION-GEN b/GIT-VERSION-GEN
index e83f9c6..cbc4be7 100755
--- a/GIT-VERSION-GEN
+++ b/GIT-VERSION-GEN
@@ -5,7 +5,7 @@
 CONSTANT = "DTAS::VERSION"
 RVF = "lib/dtas/version.rb"
 GVF = "GIT-VERSION-FILE"
-DEF_VER = "v0.17.0"
+DEF_VER = "v0.18.0"
 vn = DEF_VER
 
 # First see if there is a version file (included in release tarballs),
diff --git a/INSTALL b/INSTALL
index 85dd02b..107365a 100644
--- a/INSTALL
+++ b/INSTALL
@@ -28,10 +28,10 @@ For future upgrades of dtas
 
 Grab the latest tarball from our HTTPS site:
 
-    https://80x24.org/dtas/2019/dtas-0.17.0.tar.gz
+    https://80x24.org/dtas/2020/dtas-0.18.0.tar.gz
 
-    $ tar zxvf dtas-0.17.0.tar.gz
-    $ cd dtas-0.17.0
+    $ tar zxvf dtas-0.18.0.tar.gz
+    $ cd dtas-0.18.0
     $ sudo ruby setup.rb
 
 GNU/Linux users may optionally install the "sleepy_penguin" RubyGem